KMP算法模板 | Kyons'Blog 


 


KMP算法模板

蒟蒻学识浅陋,欢迎各位大牛指正

KMP从入门到放弃

请观左神为什么想要杀人%%%%njb7
着重听1h12m20s
$KMP$分为两个部分,一部分为两个字符串间的比较,另一部分为自己与自己的比较.
简单的划分为下面两个图,详细理解请见左神不稳定情绪讲解.
1
2
不过我$jiao$的在$1:21:04$时,将例子换为$”ababcababak”$更好理解
3

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stdio.h>
#include<stdlib.h>
#ifndef NULL
#define NULL 0
#endif
using namespace std;

char t[1000100],s[1000100];
int len1, len2,n[1000100];
void KMP(char *s,char *t)
{
for (int i = 0, j = -1; i < len1; i++) {
while (j != -1 && t[j + 1] != s[i])
j = n[j];
if (t[j + 1] == s[i])
j++;
if (j == len2 - 1) {
cout << i - len2 + 2 << endl;
j = n[j];
}
}
}
void getnext(char *t)
{
n[0] = -1;
for (int i = 1, j = -1; i < len2; i++) {
while (j != -1 && t[i] != t[j + 1])
j = n[j];
if (t[i] == t[j + 1])
j++;
n[i] = j;
}
}
int main()
{
cin >> s >> t;
len1 = strlen(s);
len2 = strlen(t);
getnext(t);
KMP(s, t);
for (int i = 0; i < len2; i++)
cout << n[i]+1 << ' ';
return 0;
}

例题

G.Oulipo

HDU 1686
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of $500000$ consecutive $’T’$s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet ${‘A’, ‘B’, ‘C’, …, ‘Z’}$ and two finite strings over that alphabet, a word $W$ and a text $T$, count the number of occurrences of $W$ in $T$. All the consecutive characters of $W$ must exactly match consecutive characters of $T$. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over ${‘A’, ‘B’, ‘C’, …, ‘Z’}$, with $1 ≤ |W| ≤ 10000$ (here $|W|$ denotes the length of the string $W$).
One line with the text T, a string over ${‘A’, ‘B’, ‘C’, …, ‘Z’}$, with $|W| ≤ |T| ≤ 1000000$.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
$BAPC$
$BAPC$
$AZA$
$AZAZAZA$
$VERDI$
$AVERDXIVYERDIAN$
Sample Output
1
3
0

解析
$kmp$模板,读入不能用$cin$,否则超时

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<stdio.h>
#include<stdlib.h>
#ifndef NULL
#define NULL 0
#endif
using namespace std;

typedef long long ll;
char t[1000100], s[1000100];
int len1, len2, n[1000100];
ll read()
{
ll f = 1,x = 0;
char s = getchar();
while (s<'0' || s>'9') {
if (s == '-')
f = -1;
s = getchar();
}
while (s >= '0'&&s <= '9') {
x = x * 10 + s - '0';
s = getchar();
}
x *= f;
return x;
}
int KMP(char *s, char *t)
{
int ans = 0;
for (int i = 0, j = -1; i < len1; i++) {
while (j != -1 && t[j + 1] != s[i])
j = n[j];
if (t[j + 1] == s[i])
j++;
if (j == len2 - 1) {
ans++;
j = n[j];
}
}
return ans;
}
void getnext(char *t)
{
n[0] = -1;
for (int i = 1, j = -1; i < len2; i++) {
while (j != -1 && t[i] != t[j + 1])
j = n[j];
if (t[i] == t[j + 1])
j++;
n[i] = j;
}
}
int main()
{
int m;
m = read();
while (m--) {
memset(n, 0, sizeof(n));
scanf("%s %s", &t, &s);
len1 = strlen(s);
len2 = strlen(t);
getnext(t);
cout<<KMP(s, t)<<endl;
}
return 0;
}

 


 


 



 //删除Valine核心代码库外链调用 //调用刚下载的本地文件以加速加载速度 //这里改为从本地加载